Yesterday, Mozilla announced that they will soon start urging Firefox users to update their old plug-ins. While there is no specific date set for when this will all begin, the change is going to primarily affect Windows users when they visit websites that involve the following programs: Adobe Reader, Adobe Flash, and Microsoft Silverlight.

Mozilla released a statement specifying why the change is necessary. 

While you are free to ignore the warnings and continue using your old plug-ins, we strongly recommend that you go to our Plugin Check page and update them as soon as possible. Old plug-in version can cause stability problems and are potentially insecure. Keeping them up to date will ensure that you have a great Firefox experience.

[via The Next Web]